Experian PreciseID Elevated Error Rate

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 12:28 EST

Monitoring

PreciseID requests are beginning to return successfully now. Our team will attempt to re-pull failed queries and monitor for continued stability.
Posted Nov 13, 2025 - 09:07 EST

Identified

We have observed an elevated error rate with Experian PreciseID. Our team has reached out to Experian support and confirmed that they are experiencing technical difficulties. We are continuing to monitor the behavior.
Posted Nov 13, 2025 - 07:59 EST
This incident affected: Third Party Systems (Experian).