Xactus360 Performance Degradation

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 08:55 EDT

Monitoring

We are monitoring the issue that was causing intermittent performance degradation in Xactus360. Product/service delivery continues to be successful.
Posted Apr 02, 2026 - 11:00 EDT

Identified

We have identified the issue that was causing intermittent performance degradation in Xactus360. Product/service delivery has resumed as expected. We are continuing to monitor.
Posted Apr 01, 2026 - 15:13 EDT

Investigating

We have identified an issue causing intermittent performance degradation in Xactus360 that is impacting product/service delivery. We are investigating and working to resolve the issue.
Posted Apr 01, 2026 - 13:28 EDT
This incident affected: Xactus360.