Social Security VerificationX

Incident Report for Xactus

Resolved

This incident has been resolved. All orders are processing and pending orders have resumed.
Posted Apr 29, 2026 - 11:00 EDT

Investigating

Users of Social Security VerificationX product may observe unexpected service disruption at this time. We are investigating the issue.
Posted Apr 29, 2026 - 10:53 EDT
This incident affected: Third Party Systems (IRS SSA).