Experian Technical Difficulties

Incident Report for Xactus

Resolved

We are no longer seeing errors with Precise ID or credit pulls. Xactus is re-submitting any requests that failed during this incident.
Posted Oct 29, 2025 - 18:08 EDT

Monitoring

Experian credit requests and Precise ID are beginning to be successful. We are continuing to monitor Experian services.
Posted Oct 29, 2025 - 17:24 EDT

Investigating

Experian is experiencing technical difficulties with some services. Due to this, Xactus is experiencing degraded performance with Credit pulls and Precise ID. We are in communication with Experian in order to resolve this.
Posted Oct 29, 2025 - 17:02 EDT
This incident affected: Third Party Systems (Experian).