Xactus360 Credit Report X Timeout Errors

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 15:49 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 15:26 EDT

Investigating

We are investigating reports of timeout errors when interacting with Credit Report X in Xactus360.
Posted Apr 10, 2026 - 14:33 EDT
This incident affected: Xactus360.