Five9 Cloud Services Degradation

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 19:09 EDT

Identified

Five9 is working to resolve issues with their cloud services vendor (GCP). There is a possibility of longer than usual hold times and/or degraded call quality until this is resolved.
Posted Jun 12, 2025 - 16:08 EDT
This incident affected: Services (Call Center).