Delayed response time in Xactus360
Incident Report for Xactus
Resolved
This issue is resolved.
Posted Oct 25, 2024 - 07:01 EDT
Monitoring
Our engineering team implemented a fix to improve performance and we're monitoring the platform to ensure resolution. The "Recent Orders" function remains disabled, but Order Search remains available.
Posted Sep 25, 2024 - 14:59 EDT
Identified
Our engineering team has identified the issue and is working on a fix. We've temporarily disabled the "Recent Orders" capability, but Order Search remains functional.
Posted Sep 25, 2024 - 14:45 EDT
Investigating
We've detected slow response times within Xactus360. Our engineers are currently investigating the issue.
Posted Sep 25, 2024 - 14:37 EDT
This incident affected: Xactus360.