Xactus360 Credit Report Merge/Unmerge Options Visibility

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted May 12, 2026 - 14:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 13:25 EDT

Update

We applied a fix that partially restored the options to users. We are continuing our efforts to fully resolve this.
Posted May 11, 2026 - 18:07 EDT

Identified

In Xactus360, the option to Merge and/or Unmerge credit reports may not be displayed for some users. We are actively working to correct this. To request support with this issue, email support@xactus.com.
Posted May 11, 2026 - 14:07 EDT
This incident affected: Xactus360.