Equifax connection failures

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 19:20 EDT

Monitoring

Error rates have returned to normal. We will monitor performance to ensure stability.
Posted Mar 27, 2026 - 18:58 EDT

Investigating

We are investigating elevated error rates with connections to Equifax.
Posted Mar 27, 2026 - 18:00 EDT
This incident affected: Third Party Systems (Equifax).