VoA - Clients are not able to select the refresh period for AccountCheck

Incident Report for Xactus

Resolved

A patch has been deployed and functionality confirmed fully restored. Clients are able to successfully select a refresh time and place an order.
Posted Mar 19, 2025 - 11:54 EDT

Identified

Users may experience problems when attempting to order the Verifications of Assets feature. A software defect has been identified, and our engineering teams are working on a patch to resolve the issue. A manual refresh workaround is available in the interim.
Posted Mar 19, 2025 - 10:07 EDT
This incident affected: Xactus360.