Experian PPR Product is Down
Incident Report for Xactus
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 15:45 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2024 - 14:39 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 26, 2024 - 13:12 EST
Identified
Clients attempting to order Experian PPR in Xactusphere are unable to complete their orders. We have identified the cause of the problem and are engaging relevant parties to implement a fix.
Posted Nov 26, 2024 - 12:50 EST