Experian Undisclosed DebtX Activation Delays

Incident Report for Xactus

Resolved

The Undisclosed DebtX missing Activations/Deactivations from 7/1/26 - 7/2/26 are currently being processed by Experian and are expected by Monday 7/13/26.
Posted Jul 10, 2026 - 14:10 EDT

Identified

Select Undisclosed DebtX activation requests sent to Experian on 7/1/2026 and 7/2/2026 have been delayed. We are actively working with Experian to resolve this.
Posted Jul 08, 2026 - 10:33 EDT
This incident affected: Credit (Undisclosed DebtX).