Elevated Error Rate for Experian PreciseID

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted May 05, 2026 - 13:30 EDT

Identified

Experian support has informed us that they are making progress with resolving the technical outage.
Posted May 05, 2026 - 12:55 EDT

Investigating

We are investigating elevated error rates observed for attempts to pull Precise ID reports from Experian.
Posted May 05, 2026 - 11:08 EDT
This incident affected: Third Party Systems (Experian).