Experian Credit and Precise ID Errors

Incident Report for Xactus

Resolved

This incident has been resolved. Experian responses are functioning as expected.
Posted May 07, 2026 - 21:36 EDT

Monitoring

Requests are beginning to return successful responses from Experian. We will continue to monitor for stability.
Posted May 07, 2026 - 21:26 EDT

Investigating

Credit and Precise ID requests to Experian are returning error responses at a high rate. We are in contact with Experian to investigate the issue.
Posted May 07, 2026 - 21:17 EDT
This incident affected: Third Party Systems (Experian).