Encompass Partner Connect Service Disruption

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 14:49 EDT

Monitoring

Encompass Partner Connect functionality has been restored by ICE. We continue to monitor performance as there may be delays with processing according to ICE.
Posted Jul 30, 2026 - 14:25 EDT

Update

ICE has restored core services, but is still working to restore Encompass Partner Network as a critical priority.
Posted Jul 30, 2026 - 11:33 EDT

Identified

ICE is currently experiencing a service disruption impacting all Encompass Partner Connect orders. This is not a Xactus specific issue.
Posted Jul 30, 2026 - 07:49 EDT
This incident affected: Platform & Access (Encompass Partner Connect (EPC)).