FraudX Reports API

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted May 29, 2025 - 18:11 EDT

Monitoring

Service performance has returned to normal after a restart was executed. We are currently monitoring to ensure stability.
Posted May 29, 2025 - 15:15 EDT

Investigating

Our systems have detected service degradation for the FraudX product API. Engineering staff is reviewing the system performance now.
Posted May 29, 2025 - 15:03 EDT
This incident affected: FraudX.