IRS ordering impacted
Incident Report for Xactus
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 14:45 EST
Identified
We have identified an issue with orders from the IRS. We are working the issue currently.
Posted Oct 22, 2024 - 16:38 EDT
This incident affected: Third Party Systems (IRS SSA).