Elevated Experian Latency and Error Rate

Incident Report for Xactus

Resolved

This incident has been resolved. Requests to Experian that received an error response during the incident window have been resubmitted by Xactus.
Posted Sep 29, 2025 - 15:07 EDT

Monitoring

Experian latency and error rate have returned to normal. We are continuing to monitor the situation.
Posted Sep 29, 2025 - 13:57 EDT

Update

Experian confirmed their services are experiencing degradation and Experian is investigating the cause.
Posted Sep 29, 2025 - 13:07 EDT

Investigating

Xactus is experiencing elevated latency and errors with credit requests sent to Experian. These requests are being retried successfully. We have contacted Experian and are investigating the issue.
Posted Sep 29, 2025 - 11:36 EDT
This incident affected: Third Party Systems (Experian).