SSN Verifications Issue
Incident Report for Xactus
Resolved
This issues has been resolved.
Posted Oct 12, 2024 - 08:17 EDT
Investigating
Our SSN verifications provider is experiencing an issue currently - we are working with them on a resolution.
Posted Oct 11, 2024 - 09:39 EDT
This incident affected: Third Party Systems (IRS SSA).