Experian Precise ID Request Errors

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted May 12, 2026 - 20:40 EDT

Monitoring

Response rates for Precise ID have returned to normal levels. We are continuing to monitor.
Posted May 12, 2026 - 20:16 EDT

Investigating

We are investigating elevated error rates with Experian Precise ID requests. Credit requests are unaffected. We are in contact with Experian.
Posted May 12, 2026 - 20:10 EDT
This incident affected: Third Party Systems (Experian).