Multiple products experiencing disruption

Incident Report for Xactus

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 20:13 EDT

Monitoring

A fix has been implemented and we are monitoring the results. It may take up to an hour for the fix to fully take effect.
Posted Apr 30, 2026 - 19:14 EDT

Identified

We are aware of a condition that is causing some products to behave unexpectedly. A fix has been identified and is currently being deployed.
Posted Apr 30, 2026 - 17:55 EDT
This incident affected: Xactus360 and FraudX.